Version Control: Unable to access Forecast 5 after update

Version Control: Unable to access Forecast 5 after update

Issue:

After running the update, Forecast 5 begins to load, the error below flashes and it closes down:

"The Forecast 5 Client you are running has a newer version than the database you are connecting to.
Ensure that the db user you are connecting with has db_owner permissions to the database"

Cause:

This is caused by the user who is running Forecast 5 has inadequate permissions to the database to complete the upgrade.

Solution:

To resolve this, ensure that all users have db_owner rights to the database and sysadmin.

Note: this process needs to be done by someone who has administrative permissions.

1. Open SSMS (SQL Server Management Studio) and connect to the Server\Instance where your Forecast 5 database is stored.


2. Under Security, expand the Logins. Right-click on the user trying to connect or use Built-In\Users and select properties


3. Go to User Mapping, select the Database and ensure db_owner has been ticked.


4. Go to Server Roles and select sysadmin.


5. Click Ok and you should now have adequate permissions to complete the upgrade of the database.


Alternatively, you can update the config file to use SA authentication which should allow the update to complete: See instructions here



    • Related Articles

    • How To Update Forecast 5

      The best way to update to the latest version of Forecast 5 is to go to www.forecast5.com/release and select the relevant version for your PC and location.
    • Unable To Activate License Manually or Online - Access Denied

      Issue: When trying to activate online or manually, you are receiving a access denied message to the following path: C:\ProgramData\Forecast5 Solution: Ensure that you have administrative permissions on your PC.  If the license still fails, go to the ...
    • Forecast 5 Support Policy

      The annual subscription includes the provision of support to an end user, access to the online training videos, continued use of the product and access to updates and releases.  You have access to the Forecast 5 Knowledge Base, available ...
    • Update: Could not connect to Forecast 5 Auto-Update Server.

      Issue: Could not connect to Forecast 5 Auto-Update Server. Next try in 1 day. You may receive this error when launching Forecast 5. As the error suggests, Forecast 5 is being blocked from connecting to the F5 update server.   To resolve this add the ...
    • Forecast 5 User Guide

      Contents Activating Your Forecast 5 License ........................................................................................................3 Having Trouble Activating Your Forecast 5 License? ...