Issue
I am trying to export or copy a forecast and it is taking a long time, then says it is not responding.
Should I crash out?
Answer
No, do not crash out of Forecast 5.
Although windows is saying that Forecast 5 is not responding, Forecast 5 is still processing in the background.
Cause
Microsoft windows will occasionally display with Not Responding in Forecast 5. This happens because the processing that is happening is quite high volume and is happening in the background, in the SQL Server that Forecast 5 uses as a database. Because the processes are happening in the background, Microsoft can't get the handshake from the front end of Forecast 5 to confirm it is still working.
Usually this occurs if you are trying to export/copy a large forecast and either your PC is not meeting the
system requirements or you are using the localdb (the default option that is installed with Forecast 5).
Upgrading to SQL Express can improve the export/copy speed significantly. Here is an article to upgrade but please bear in mind that this uses SQL Express, which requires some experience.
From feedback we have received, it may take you over an hour to complete this process if you have no experience with SQL but, on average, takes F5 consultants, 20 minutes. It is strongly recommended you request the assistance of a Forecast 5 consultant or your IT people.